Watermelon - CXhub not showing on website – Incident details

All systems operational

CXhub not showing on website

Resolved
Major outage
Started about 4 years agoLasted 15 minutes

Affected

Updates
  • Resolved
    Resolved

    This incident has been resolved

  • Identified
    Identified

    The issue has been identified and a fix is being implemented. We are sorry for the inconvenience.