Watermelon - Some services are down – Incident details
All systems operational
Some services are down
Resolved
Major outage
Started about 5 years agoLasted about 11 hours
Updates
Resolved
Resolved
Our development team has resolved the issue. If you continue to experience problems, please let us support team known via email to support@watermelon.co. We apologize for any inconvenience
Identified
Identified
The issue has been identified and a fix is being implemented.